Community Forums

3ds Max Training

+ Reply to Thread
Results 1 to 5 of 5
  1. #1

    Raytrace Shadows' softness and Shadow Map

    Hi guys, just posting my first thread here at DT... I need a help with my Shadow Maps, actually, there aren't any and that's the problem, only raytraced shadows show up in the render. I'm using 3DS Max 2011 with Mental Ray.
    Do you guys guess what might be wrong?
    By the way, how can I apply softness to a shadow using Raytrace. In XSI you have Softness parameter, it's so easy. I uses Sample Range for the softness equivalent when using Shadow Maps, and rise the Size value because of the bad quality of the it when trying to make the shadow's border sharper.

    Thanks a lot!

  2. #2
    Join Date
    Nov 2002
    Location
    DT HQ
    Posts
    547
    DT Staff
    I am a Face of Change

    Re: Raytrace Shadows' softness and Shadow Map

    If you want to get soft raytraced shadows in mental ray, you'll need to use the "mr Area Omni" or the "mr Area Spot" light type.

    Those 2 light types have an "Area Light Parameters" roll-out, where you can adjust the radius of your light source. Higher radius values will produce softer shadows.

    Good luck, hope this helps
    Kyle

    Thank you all for supporting Digital-Tutors.

  3. #3

    Re: Raytrace Shadows' softness and Shadow Map

    Thank you Kyle!
    The Area Lights do work.
    But, what about my Shadow Maps that don't cast any shadow? What's wrong with them?
    Thanks!

  4. #4

    Re: Raytrace Shadows' softness and Shadow Map

    Kyle,

    I'm having the same problem. Shadow maps not showing up with a standard spot light using mental ray and mental ray materials. Increasing the size of the shadow map does not help. All is fine if I use ray traced but I'm trying to demonstrate the difference between shadow maps and ray traced maps to my students.

  5. #5
    Join Date
    Nov 2002
    Location
    DT HQ
    Posts
    547
    DT Staff
    I am a Face of Change

    Re: Raytrace Shadows' softness and Shadow Map

    Hi Artistman,
    I've sometimes seen this happen when opening up existing scenes (usually from older versions of 3ds Max), and trying to add lights.

    After you create your light and enable the Shadow Map shadows, go to the "Shadow Map Params" roll-out of the light, and make sure your "Bias" is set to a low value like 0.01. Sometimes the Bias will default to a value of 1.0, which makes the shadow completely disappear.

    Good luck, hope this helps
    Kyle

    Thank you all for supporting Digital-Tutors.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts