Community Forums

Maya Training

+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 17
  1. #1
    Join Date
    Mar 2010
    Location
    Boulder Creek, CA
    Posts
    3

    Maya 2011 Lesson: Isolate Shadows with the Use Background Shader

    I'm working on this lesson, but I seem to be stuck. I've redone it several times, and gotten the same results each time (even after going back to the default preferences, in case the issue was there).

    When I bring in the ground plane, it renders as a grey lambert. It does not show the reflections and shadows as in the tutorial. I tried continuing on, with similar results. When I apply a new material of UseBackground, I don't get a green plane. It stays grey. I tried adjusting the settings, as he does in the next step, but it still doesn't work.

    Did I make a mistake with the lighting? Or is there a setting I need to change somewhere?

    Here are attachments of my render results and a screen shot of my UseBackground settings.
    Attached Images

  2. #2
    Join Date
    Oct 2006
    Location
    Digital Tutors HQ
    Posts
    2,509
    DT Staff

    Re: Maya 2011 Lesson: Isolate Shadows with the Use Background Shader

    Hi JessieBababy,

    Are you sure the lights have shadows turned on? you may also need to bump up your Raytracing Shadows. Render Settings -> Quality -> Raytracing -> Shadows set so something higher than 2, like 3, 4 or 5.

  3. #3
    Join Date
    Mar 2010
    Location
    Boulder Creek, CA
    Posts
    3

    Re: Maya 2011 Lesson: Isolate Shadows with the Use Background Shader

    Well, I kind of found the issues. First, I needed to hit 5 (I was on 6) to see that the plane was green. Then, last night, I went through the lighting lesson again. What I ended up with was a black reflective surface . . . like a puddle. I turned the reflective aspects off, and ended up with a flat black surface again.

    In the Attribute Spread Sheet, "Use Raytrace Shadows" is set to on for all the lights. The sunlight shape were set at 5, and the rest were at 7. I just tried bumping them all up to 10 and still have a black ground plane.

    Last night, I googled the issue and found other people having that problem when they added domes to their scenes. I took the dome out. When I remove the dome, it works fine.

    Putting the dome back in, I have Cast Shadows and Receive Shadows turned off. And it still didn't work. I even tried importing the dome that comes in the lesson files.

    Ok. I just experimented more with the imported dome's Render Stats. I unchecked everything except Visible in Reflections and Visible in Refractions. I now have a ground with shadows! So it works the way I have it, but is there a better setting to use?

    Thanks for your help! =)

  4. #4
    Join Date
    Oct 2006
    Location
    Digital Tutors HQ
    Posts
    2,509
    DT Staff

    Re: Maya 2011 Lesson: Isolate Shadows with the Use Background Shader

    Hi JessieBababy,

    No problem! Always glad to help. I believe that you should be able to only un-check 'Primary Visibility' and get the same result. I'm not getting the same result when working with regular geometry, but maybe the dome is acting differently.

    Let us know if you have any other questions!

  5. #5
    Join Date
    Mar 2010
    Location
    Boulder Creek, CA
    Posts
    3

    Re: Maya 2011 Lesson: Isolate Shadows with the Use Background Shader

    OK. Thanks!

  6. #6

    Re: Maya 2011 Lesson: Isolate Shadows with the Use Background Shader

    I now have exactly the same problem as Jessie =(
    Dont know whats wrong !!

  7. #7

    Re: Maya 2011 Lesson: Isolate Shadows with the Use Background Shader

    Hmm...when I delete the dome I can see the shadows but now i loose my nice reflections from the surroundings.
    Have you got any idea why this happnes?

  8. #8
    Join Date
    Oct 2010
    Posts
    2,783
    DT Staff

    Re: Maya 2011 Lesson: Isolate Shadows with the Use Background Shader

    Hi! Here's a quick video that goes through some of the render stats in that particular scene to get the shadows rendered out with the Use Background shader.

    Last edited by dan; 01-17-2011 at 02:27 PM.

  9. #9

    Same Problem Here

    I have the exact same problem as JessieBababy...

    The video in this thread just reiterated what were were told in the lesson. I had already done those things, as instructed in the lesson, and I ended up with the exact same result as JessieBababy-- an opaque black Ground Plane.

    It must be the Dome... If I turn off "Double-Sided" in the Render Stats for the dome, I get the shadows on the Ground Plane, the Plane is transparent, but there are no reflections in the racer.

    Please HELP! It's frustrating to go this far in the course and have to stop before I'm even done.

    Thanks,

    brianc

  10. #10
    Join Date
    Nov 2010
    Location
    Cuba
    Posts
    8

    Re: Maya 2011 Lesson: Isolate Shadows with the Use Background Shader

    Are you using a polygon sphere for the dome or an IBL node? The thing is that the UseBackground shader has issues with a polygon sphere as a dome. Instead try using the IBL node.

  11. #11

    Re: Maya 2011 Lesson: Isolate Shadows with the Use Background Shader

    Hey!

    I have been having this problem for along time. Im not using a dom in this case. I am using physical sky. The use background is visibel for maya i guess, because it shows the final gather.

    I tested this set up in an other scen with out succes.

    I really need help !

    Marcus(Sweden)

  12. #12
    Join Date
    Oct 2010
    Posts
    2,783
    DT Staff

    Re: Maya 2011 Lesson: Isolate Shadows with the Use Background Shader

    Hello Marcus! The Use Background shader doesn't play well with Final Gather. On the other side, Physical Sun & Sky requires Final Gather. So one way to get both in your final render is to set them up on separate render layers and then composite them back together in post. Here's a look at how you can do that. Hope it helps!


    Here's a link to the Compositing 3D into Video in Maya and Toxik course that was referenced in the video.

  13. #13

    Re: Maya 2011 Lesson: Isolate Shadows with the Use Background Shader

    I've been playing around with this the last few hours and I've experienced the same issues... I did two things which I believed helped...

    First, make sure that your poly plane doesn't extend beyond the size the of pSphere. I was getting this weird edge falloff earlier and I suspect it could have been due to this.

    Second, with the pPlane, go into your attributes and go to the 'pPlaneShape1' tab... Under 'Render Stats', only have Receive Shadows and Primary Visibility active (yes, this still left me with a giant black plane in my renders) BUT then I opened up the mental ray tab (two more tabs down) and turned off all the checked marked options... "visible in transparency, transmit transparency, trace reflection, transmit refraction, final gather, etc', Once I turned these all off... the render magically worked for me.

    Perhaps I'm now losing some other qualitative function... I don't know... but it does remove all the weird 'solid plane' issues I had and managed to allow me to keep the dome in play. Hope this helps a few people.

  14. #14

    Re: Maya 2011 Lesson: Isolate Shadows with the Use Background Shader

    thanks Geoff, you nailed it!

  15. #15

    Re: Maya 2011 Lesson: Isolate Shadows with the Use Background Shader

    Also dealt with this issue, and Geoff's solution worked (thanks!)

    Now, in my case it was sufficient to turn off only "Final Gather Receive" under the mental ray settings of the ground plane's shape node (as Geoff directed); every other option was left on (even under the Render Stats tab) and it still worked. This is either all that's necessary, or my case was unique for whatever reason (I was working on a project of my own, not the referenced tutorial).

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts